Mercury Gate Maintenance
Incident Report for Mercury Cash
Identified
We have identified an issue with Gate orders and we are working to release a hotfix to solve this situation. We will keep you posted.
Posted Apr 16, 2021 - 10:25 EDT
Monitoring
We are implementing fixed in our Mercury Gate Backend, we are monitoring the results if you have any issue doing transactions with Mercury Gate, please contact customer support reporting the issue.
Posted Apr 15, 2021 - 08:09 EDT
This incident affects: Gate Website.