Dash Delayed Transactions
Incident Report for Mercury Cash
Resolved
This incident has been resolved.
Posted 15 days ago. Sep 04, 2019 - 15:12 EDT
Monitoring
We have identified that DASH transactions started to normalize, we will continue to monitor the situation for a couple of hours more until mark this issue as resolved.
Posted 16 days ago. Sep 03, 2019 - 13:52 EDT
Identified
Dear users, we have identified an error with our Dash Network nodes, our engineers have applied a fix and we are expecting to have the network fully operational in couple minutes while all the nodes sync the blockchain.

If you are expecting a transaction this will be delayed until the network is completely synced.
Posted 16 days ago. Sep 03, 2019 - 13:28 EDT
This incident affected: Nodes (Dash Network).