General Issues with Certificates
Incident Report for Mercury Cash
Resolved
We have applied a fix and all issues are resolved, however, we will keep monitoring the situation closely.
Posted about 2 months ago. Jul 25, 2019 - 15:28 EDT
Investigating
One of our API certificates is presenting issues, we are currently investigating to apply a fix as soon as possible.
Posted about 2 months ago. Jul 25, 2019 - 13:38 EDT
This incident affected: API, Website, ID Verification, Digital Currencies, Customer Support, Cryptocurrency Purchases and Website (Login, Sign Up, KYC Verification, SMS Verification).